Jump to content

Zgemma H2S, Evo NOVA Twin.


kusiu
 Share

Recommended Posts

  • Replies 230
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Już jest OK, skórka nie wywołuje GS, reszta tzn. położenie klawiatury się nie zmieniło.

Dlatego jak ktoś chce nam pomóc to warto się przełączyć na gałąź TEST tam prawie codziennie są jakieś aktualizacje i nowe funkcje i pakiety w przeciwieństwie do gałęzi release gdzie update występuje co miesiąc. Wtedy dużo szybciej wyłapuje się potencjalne błędy i je naprawiamy zanim przerzucimy do release pakiety.

Skórki jeszcze nie aktualizowałem.

Link to comment
Share on other sites

W przypadku MIPS32EL mamy do dyspozycji (piszemy o tunerach wspieranych przez GOS) co najmniej 256MB FLASH z czego co najmniej około 200MB jest dostępne dla systemu operacyjnego.

W efekcie to czego bardzo często brakowało w SH4 a było "systemowe" jest w MIPS32EL standardowo jak w każdym innym Linux.

Tutaj nie tniemy wszystkiego jak inny a wręcz przeciwnie - nawet jak system ma zajmować więcej to...to będzie zajmował więcej. Trudno. Ale za to nie ma problemów z obsługą.

Link to comment
Share on other sites

Witam, mam pytanie odnośnie formatowania dysku i karty SD.

 

dysk 1 TB karta 16 GB

 

jak sformatować żeby nie było problemów z montowaniem ?

 

GraterliaOS:~# fdisk -l
Disk /dev/mtdblock0: 256 MiB, 268435456 bytes, 524288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mtdblock1: 6 MiB, 6291456 bytes, 12288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mtdblock2: 250 MiB, 262144000 bytes, 512000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mmcblk0: 14.6 GiB, 15707668480 bytes, 30679040 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000aae8b

Device         Boot Start      End  Sectors  Size Id Type
/dev/mmcblk0p1 *     2048 30679039 30676992 14.6G  c W95 FAT32 (LBA)


Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Link to comment
Share on other sites

możecie sprawdzić czy wszystko jest ok.


GraterliaOS:~# fdisk -l
Disk /dev/mtdblock0: 256 MiB, 268435456 bytes, 524288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mtdblock1: 6 MiB, 6291456 bytes, 12288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mtdblock2: 250 MiB, 262144000 bytes, 512000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mmcblk0: 14.6 GiB, 15707668480 bytes, 30679040 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000aae8b

Device         Boot Start      End  Sectors  Size Id Type
/dev/mmcblk0p1       2048 30679039 30676992 14.6G 83 Linux


Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x684ab7dc

Device     Boot Start        End    Sectors   Size Id Type
/dev/sda1        2048 1953525167 1953523120 931.5G 83 Linux

 

Link to comment
Share on other sites

  • 2 weeks later...

Wrócę jeszcze do tematu związanego z celowym lub przypadkowym (zanik zasilania) restartem Zgemmy.

Temat z utratą czasu systemowego wydaje się być ogarnięty dzięki poradzie TomTelos[/member] i wtyczce systemtime.

Kłopot jest inny. Tak się składa, że mam dwa bukiety TV, ten z którego korzystam i ten jakby wbudowany Favourities (pusty).

Po powstaniu po restarcie, Zgemma ustawia bukiet Favourities. Trzeba ręcznie kliknąć niebieski i przełączyć się na właściwy bukiet.

 

Można jakoś ustawić bukiet "domyślny", coś a'la kanał startowy ?

Link to comment
Share on other sites

No dobrze. Ale ja jestem świadom istnienia i funkcji guzika MENU w różnych kontekstach.

Kanał startowy oczywiście działa ok. Załączam SS z guzika MENU na bukiecie. Niestety nie widzę tam opcji która pozwala ustawić domyślny bukiet. Po restarcie systemu ustawia się pustak - Favourities. Co przeoczyłem ?

menu.JPG.efa6b063c3fe1bb81d2c408fd9ad917b.JPG

Link to comment
Share on other sites

Panowie, dzięki za cierpliwość :)

Możliwe że ja coś źle tłumaczę. Nie chodzi o kanał startowy a o bukiet startowy.

Załączam jeszcze dwa SS. Po restarcie - pusto, świeci tylko plansza GOS. Pod OK pusty ekran (bez kanałów).

Muszę użyć Niebieskiego i ręcznie przełączyć na bukiet NC+, który BTW jest na topie listy. Od tej chwili wszystko gra, do kolejnego restartu.

Dodałem "z ręki" dla testu kilka bukietów (pustych) z NC+ na topie. To nie to.

Bukiet.JPG.b811665b8dc0353a31e9444c9b99e0a0.JPG

po_restarcie.JPG.365e40a1e1fcef312e0e7eb9c6e2ac33.JPG

Link to comment
Share on other sites

Właśnie sprawdziłem.

Jest tak samo, muszę ręcznie wybrać bukiet.

Ciekawe jest to, na screenie też to widać, że on wcale się nie ustawia (jak początkowo myślałem) na pustym bukiecie Favourities, ścieżka brzmi Bukiety/ tak jakby był w jakimś katalogu domowym.

 

-------------------

Dzięki pomocy tux'a problem rozwiązany. Nie dość że błyskawicznie to jeszcze otrzymałem garść pożytecznych porad na przyszłość.

Dzięki !

Link to comment
Share on other sites

Czy to, że dekoder nie puszcza uprawnień na kartę to wina oscam'a? Muszę go jakoś skonfigurować, zmienić wersję? Nie wiem od czego zacząć poszukiwanie problemu.

Link to comment
Share on other sites

Czy to, że dekoder nie puszcza uprawnień na kartę to wina oscam'a? Muszę go jakoś skonfigurować, zmienić wersję? Nie wiem od czego zacząć poszukiwanie problemu.

 

z dużą dozą prawdopodobieństwa to wina złych ustawień oscama,

zacznij od rozglądnięcia się po forum i zaglądnięcia od właściwej jego sekcji.

 

Link to comment
Share on other sites

Gdzieś widziałem ale nie mogę znaleźć: jak powinny być skonfigurowane tunery A i B jak mam dwa kable?

Tylko 1 satelita HB.

 

 

Też mam dwa kable, oba tunery skonfigurowane tak:

 

Tryb konfiguracji: Prosty

Tryb: Jeden

Satelita: 13.0 Eutelsat Hot Bird ......

Wysyłanie DiSEqC: NIE

 

Link to comment
Share on other sites

Czy to, że dekoder nie puszcza uprawnień na kartę to wina oscam'a? Muszę go jakoś skonfigurować, zmienić wersję? Nie wiem od czego zacząć poszukiwanie problemu.

 

z dużą dozą prawdopodobieństwa to wina złych ustawień oscama,

zacznij od rozglądnięcia się po forum i zaglądnięcia od właściwej jego sekcji.

 

Poszedłem po najmniejszej linii oporu, czyli podegrałem konfigi dla karty nc+ seca. Czy da się gdzieś z poziomu menu albo z konsoli sprawdzić datę uprawnień?

Link to comment
Share on other sites

A masz ustawiony czas?

Pytam bo doszła nowa opcja i nie mam pojęcia czy to nie spowodowało, że ustawiania są teraz inne.

Jeżeli masz ustawione OK to znaczy, że może być to BUG i póki co jesteś jedyną osobą, która to zgłasza.

Link to comment
Share on other sites

A masz ustawiony czas?

Pytam bo doszła nowa opcja i nie mam pojęcia czy to nie spowodowało, że ustawiania są teraz inne.

Jeżeli masz ustawione OK to znaczy, że może być to BUG i póki co jesteś jedyną osobą, która to zgłasza.

 

Co masz na myśli pisząc "ustawiony czas" ? Czas systemowy czy usypianie dysku po czasie ? Jedno i drugie ok. Zmiana tego drugiego na inną wartość przekłada się na wpis w /etc/enigma2/settings więc wszystko wygląda poprawnie a dysk się kręci.

Link to comment
Share on other sites

GraterliaOS:~# sysupdate

Upgrading gosscripts from 1.0.31 to 1.0.32 on root.

Upgrading gosscripts (1.0.32) on root.

Downloading http://repository.graterlia.xunil.pl/release/mips32el/gosscripts_1.0.32_mips32el.ipk.

Upgrading graterlia-opkg-repository-configs from 1.0-3 to 1.0-4 on root.

Upgrading graterlia-opkg-repository-configs (1.0) on root.

Downloading http://repository.graterlia.xunil.pl/release/zgemmah2s/graterlia-opkg-repository-configs_1.0-4_zgemmah2s.ipk.

To remove package debris, try `opkg remove graterlia-opkg-repository-configs`.

To re-attempt the install, try `opkg install graterlia-opkg-repository-configs`.

Configuring gosscripts.

Collected errors:

* pkg_run_script: package "graterlia-opkg-repository-configs" preinst script returned status 1.

* preinst_configure: Aborting installation of graterlia-opkg-repository-configs                                                                                                                                                              .

Po  opkg update && opkg upgrade  sysupdate pokazuje że wszystko jest aktualne.

Link to comment
Share on other sites

Po ostatniej aktualizacji przestało działać mi WiFi.

Miał ktoś coś podobnego ?

Widzi kartę ale nie może się połączyć do sieci, testowane na 3 kartach wifi i na w wszystkich portach usb.

Lan działa

Link to comment
Share on other sites

Kilka dni temu aktualizacja tunera zatrzymała mi się bodajże na pakiecie glibc - stała tak kilkanaście minut i postanowiłem zrestartować boxa. Po restarcie już nie wstał. No to nowa instalacja i powstał problem z zamontowaniem udziału nfs. Zauważyłem po jakimś czasie, że w menu "sieć" nie mam zielonej kropki "Połączenie". Zrobiłem test sieci i w linii "Sieć lokalna" mam wpis "Nieznany". Być może w tym tkwi problem? Oczywiście połączenie sieciowe działa wg mnie prawidłowo - epgimport czy yweather prawidłowo pobierają dane.

Zauważyłem także, że uruchomiona jest obsługa IPv6 która nie jest w mojej sieci używana.

Czy do obsługi nfs jest potrzebna instalacja jakiegoś dodatkowego pakietu? Poprzednio, wydaje mi się, że niczego specjalnego nie instalowałem i działało.

Pozdrawiam

Link to comment
Share on other sites

W uzupełnieniu poprzedniego posta.

 

Próba ręcznego zamontowania zasobu daje następujący wynik:

[root@Zgemma ~]# mount -t nfs 192.168.2.2:/nfs/nagrania /mnt
mount: /mnt: bad option; for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program.

 

Na drugim dekoderze (nbox) ten sam zasób montuje mi się zarówno z menu jak i ręcznie bez żadnych problemów.

Link to comment
Share on other sites

 

Wykonywałem to wielokrotnie, ale w opisie pakietów nfs-utils jest błędny opis

nfs-utils - 1.2.8 - Userspace utilities for kernel nfs  The nfs-utils package provides a
daemon for the kernel NFS server and   related tools.
nfs-utils-miniclient - 1.2.8 - Userspace utilities for kernel nfs  The nfs-utils package provides a
daemon for the kernel NFS server and   related tools.

Wynika  z niego, że oba pakiety dotyczą serwera nfs - więc nie instalowałem. Sprawdziłem też w nbox-ie - tam nie mam zainstalowanego pakietu nfs-utils, a montowanie nfs działa.

 

Po zainstalowaniu nfs-utils-miniclient próba ręcznego montowania po nfs kończy się tak:

[root@Zgemma ~]# mount -t nfs 192.168.2.2:/nagrania /mnt
mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: mounting 192.168.2.2:/nagrania failed, reason given by server: No such file or directory

Pomagało dodanie parametru  '-o nolock', ale montowanie przez menu nie działało. 

Zauważyłem, że montowanie po nfs4 przebiega poprawnie. Zacząłem szukać jakiegoś rozwiązania i przy tym restartowałem boxa kilkukrotnie. Postanowiłem dopisać do fstab-a montowanie po nfs4. Po restarcie okazało się, że w międzyczasie zadziało montowanie poprzez menu (pozostawiłem wpis) i  udział mam zamontowany dwukrotnie. Usunąłem zatem wpis w fstab, restart i zadziałało montowanie przez menu.

 

Montowanie ręczne pozostało jak wyżej.

 

Ale cel osiągnięty, dzięki za pomoc.

 

PS

Popraw proszę opis pakietu nfs-utils-miniclient.

Link to comment
Share on other sites

Dziś zainstalowałem soft od nowa. Niby wszystko ok, ale ...

1. Gdy dekoder jest bez karty uruchamia się bardzo szybko.

2. Gdy jest włożona karta 128 GB dekoder uruchamia się 8 min. Większość czasu mija na 13% (nie wiem co się wtedy robi). Karta sformatowana na ext3. Formatowałem na ext4 też bez efektu. Jest zamontowana pod /media/hdd zgodnie z odhashowaną linijką w fstab.

3. Timeshift się nie włącza mimo ustawionej opcji w menu "start po 5s".

4. Zmiana ścieżki z /hdd/timeshift na /media/timeshift i próba zapisania zwraca komunikat, że w tej lokalizacji jest mało miejsca czy kontynuować?

5. Po świeżym formatowaniu i ręcznym montowaniu pokazuje prawidłowo użycie dysku. Po restarcie systemu zaczyna się wszystko od nowa. Od pkt. 1.

6. W opcjach mam ustawione by przechodził w stan czuwania po uruchomieniu to też mi nie działa.

7. Komenda "mkdir /hdd/timeshift" zwraca komunikat:

 

GraterliaOS:/hdd# mkdir /hdd/timeshift
mkdir: cannot create directory ‘/hdd/timeshift’: No space left on device
GraterliaOS:/hdd#

 

Czy jest na to jakieś rozwiązanie??

 

GraterliaOS:/# df -h
Filesystem      Size  Used Avail Use% Mounted on
ubi0:rootfs     217M  126M   92M  59% /
devtmpfs        153M  4.0K  153M   1% /dev
tmp             153M  8.0K  153M   1% /tmp
run             153M   32K  153M   1% /run
/dev/mmcblk0    121G  121G     0 100% /media/hdd
GraterliaOS:/#

 

Na zdjęciu widać, że nic tam nie ma.

 

Co zrobiłem źle?

hdd.thumb.jpg.2f2f2631081a0465d376f7512e5b4005.jpg

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...