Jump to content
TomTelos

YouTube

Recommended Posts

Przepraszam, będą poprawki. Dużo tekstu mam wygenerowane z automata muszę to jeszcze przelecieć ręcznie. ;)

Poza tym wtyczka jest dopiero w test także spokojnie.

Share this post


Link to post
Share on other sites
Guest g01

U mnie podczas odtworzenia czegokolwiek wyskakuje napis "Wystąpił błąd podczas wyodrębnianiu widea z adresu url: [Errno -2] Name or service not known"

Share this post


Link to post
Share on other sites
Guest g01

GraterliaOS:~# opkg list-installed
alsa-libs - 1.0.29-1
autofs - 4.1.4.6
busybox - 1.24.1-3
cron - 4.1-3
curl - 7.45.0
curl-libs - 7.45.0
dev-gos - 1.0.16
e2fslibs - 1.42.13-1
e2fsprogs - 1.42.13-1
enigma2 - 2015-11-27-git-1
enigma2-data - 2015-11-27-git-1
enigma2-default-fonts - 0.2.0
enigma2-i18n-default - 2015-11-13-1
enigma2-keymaps - 2015-05-13-git-2
enigma2-libs-metapack - 1.0.10
enigma2-picon-hotbird-richter-polskie-220x132 - 2015-10-07
enigma2-picon-weather-style-01 - 1.0.0
enigma2-picon-weather-style-default - 1.0.1
enigma2-plugin-ava - 1.3-2
enigma2-plugin-cec - 0.3.9
enigma2-plugin-coverfind - 0.9.2-1
enigma2-plugin-dmnapi - 15.11.08-1
enigma2-plugin-dreamexplorer - 0.2.2
enigma2-plugin-fancontrol - 1.14.3
enigma2-plugin-foreca - 3.1.6-1
enigma2-plugin-freeplayer - 1.63.9
enigma2-plugin-frontpanel - 2.0.8
enigma2-plugin-graphmultiepg - 0.2.6
enigma2-plugin-numberzapext - 1.0-rc4a-2
enigma2-plugin-openwebif - 0.4.7-2
enigma2-plugin-permamentclock - 0.2.2
enigma2-plugin-skinselector - 0.2.1
enigma2-plugin-userskin - 0.2.35
enigma2-plugin-userskin-i18n-default - 0.2.28
enigma2-plugin-videomode - 0.2.2
enigma2-plugin-weathercomponenthandler - 0.2.1
enigma2-plugin-youtube - 2015.11.24
enigma2-plugin-yweather - 0.1.3
enigma2-plugin-zaphistorybrowser - 2.0.0
enigma2-plugins-default - 2015-08-25-git-1
enigma2-skin-default - 2015-11-17-tux-1
enigma2-skin-infinityhd-gos - 2015-11-10-1
enigma2-skin-metrixhd - 2015-10-11-2
ethtool - 6.0.0
expat-libs - 2.1.0-1
exteplayer3 - 2.0.2
ffmpeg - 2.8.2-1
ffmpeg-libs-core - 2.8.2-1
ffmpeg-libs-ext - 2.8.2-1
flac-libs-gos - 1.3.1-1
font-ae-almateen - 0.2.0
font-aller - 1.00.0
font-analog - 1.00.00
font-andale - 0.2.0
font-cool - 0.2.0
font-digi - 1.00.00
font-droid - 1.00.107
font-handelgotd - 0.2.0
font-lcd - 0.2.0
font-liberation - 1.04.0
font-meteocons - 0.2.0
font-nmsbd - 0.2.0
font-opensansregular - 0.2.0
font-ralewaychannel - 2.002.0
font-ralewaylight - 2.002.0
font-roboto - 1.100141.1
font-setrixhd - 1.00.00
font-tuxtxt - 0.2.2
font-ubuntu - 0.80.0
font-valis-enigma - 0.2.0
font-venusrisingregular - 4.101.0
font-verdana-r - 0.2.0
freetype - 2.6.0-1
giflib - 6.5.0.6
glib-networking - 2.45.1-1
glib2-gos - 2.45.4-1
glibc-gos - 2.14.1-56
glibc-libcrypt-gos - 2.14.1-53
graterlia - 2.1.17
graterlia-core - 2.0
graterlia-locale-pl - 2.14.1
graterlia-logo - 1.0.9
graterlia-manager - 0.1.167
graterlia-manager-i18n-default - 0.1.110
graterlia-scripts - 0.1.271
graterlia-system-core-metapack - 2.1.4
gst-plugins-bad-gos - 1.6.1-2
gst-plugins-base-gos - 1.6.1-2
gst-plugins-good-gos - 1.6.1-2
gst-plugins-ugly-gos - 1.6.1-2
gstreamer-gos - 1.6.1-2
gstreamer-gos-tools - 1.6.1-2
hdparm - 9.45
kernel-core-default-gos - 2.6.32.61.0217.01
kernel-modules-cec-gos - 2.6.32.61.0217.01
kernel-modules-default-gos - 2.6.32.61.0217.01
kernel-modules-fan-gos - 2.6.32.61.0217.01
libass - 5.0.11.1
libavresample - 1.1.0
libblkid1 - 2.27-1
libbz2 - 1.0.6-1
libcap - 2.16.0
libcomerr2 - 1.42.13-1
libdca - 0.0.5
libdreamdvd - 0.0.5
libdvbsi++ - 0.3.7-1
libdvdnav - 4.2.1
libdvdread - 4.9.9
libexif - 0.6.20
libexslt - 0.8.17
libffi - 6.0.4
libgcc-gos - 4.8.3-135
libgcrypt - 1.4.4
libgmp - 6.0.0-1
libgnutls - 3.4.3-1
libgpg-error - 1.10.6
libid3tag - 0.15.1b-1
libjpeg-turbo - 1.2.1-5
libmad - 0.15.1b-1
libmme-libs - 1.0.4
libmodplug - 0.8.8.4-1
libmount1 - 2.27-1
libmpc - 1.0.2-1
libnettle - 3.1-2
libogg - 1.3.2
libopen - 1.0.0-2
liborc - 0.4.24
libpng - 1.6.18-1
libproc - 3.2.8
librtmp - 2.4.6
libsigc++ - 1.2.7
libsmartcols - 2.27-1
libsoup - 2.50.0-1
libsqlite3 - 3.8.6
libss - 2.0.2
libstdc++ - 4.8.3-145
libtermcap - 2.8.0
libtuxtxt - 1.99.1-2
libuuid1 - 2.27-1
libvorbis - 1.3.4
libwrap-libs - 7.6.0
libxml2 - 2.9.0-1
lirc-libs - 0.9.0-1
minidlna - 1.1.3-4
mpfr - 3.1.2-9
ncurses-libs-gos - 5.9-1
ntpdate - 1.0.3-12
openssl - 1.0.2-1
opkg - 0.2.4-11
oscam-webif - 1.20-r11179-1
procps - 3.2.8
python-base-gos - 2.7.9-1
python-cheetah-gos - 2.4.4-2
python-crypto-gos - 2.5-3
python-elementtree-gos - 1.2.6-20050316-1
python-openssl-gos - 0.13.1
python-twisted-base-gos - 13.2.0-1
python-usb-gos - 1.0.0a3-1
python-wifi-gos - 0.5.0-1
python-zope-interface-gos - 4.1.1-1
readline - 6.2-1
remote-gos - 1.0.23
sdparm - 1.09-1
smartmontools - 6.4.0
sti-firmware-audio - 1.0.1
sti-firmware-video - 1.0.1
stm-utils - 1.0.9
system-core - 2.1.19
sysvinit - 2.88.0dsf-26
util-linux-gos - 2.27-1
vsftpd - 3.0.3-1
zlib - 1.2.8-1
GraterliaOS:~#

 

instalowałem z GOS menadżer

Share this post


Link to post
Share on other sites
Guest g01

Wygląda na to że masz dobrze, powiedz mi czy wcześniej już wgrywałeś manualnie paczkę youtuba przez ftp przed dodaniem do opkg?

 

Chyba tak wcześniej była tu jakaś wersja youtube ale nie działała.

Ale teraz jak pobierałem tę aktualną  wtyczkę to pobierało jeszcze jakieś dodatkowe pakiety i przy jednym pakiecie był chyba Error.

Share this post


Link to post
Share on other sites

Wejdź do /usr/lib/enigma2/python/Plugins/Extensions/YouTube sprawdź czy tam nie masz jakiś plików z końcówką  ".py" . Jak są, to wywal wszystko z stamtąd i zrób reinstalacje wtyczki youtuba w opkg.

Share this post


Link to post
Share on other sites
Guest g01

Wejdź do /usr/lib/enigma2/python/Plugins/Extensions/YouTube sprawdź czy tam nie masz jakiś plików z końcówką  ".py" . Jak są, to wywal wszystko z stamtąd i zrób reinstalacje wtyczki youtuba w opkg.

 

Nie było plików ",py" W katalogu YouTube, odinstalowałem potem zainstalowałem z powrotem dalej ten sam błąd wyskakuje.

 

Share this post


Link to post
Share on other sites
Guest voyteckst

Odtwarza Wam płynnie materiały wideo? U mnie tylko na początku a po chwili tnie.

 

Sent from my SGP612 using Tapatalk

 

 

Share this post


Link to post
Share on other sites
Guest herpoi

Idzie płynnie całość. Może łącza ci nie starcza. W ustawieniach wtyczki można ustawi jakość video jaką wtyczką ma wybierać.

 

Share this post


Link to post
Share on other sites

Odtwarza Wam płynnie materiały wideo? U mnie tylko na początku a po chwili tnie.

 

Sent from my SGP612 using Tapatalk

 

Twój nBox korzysta z LAN czy WIFI? Mi na nboxie spokojnie idzie 720p przy WIFI.

Share this post


Link to post
Share on other sites
Guest voyteckst

Mam LAN, ale to i tak chyba powinno wystarczyć?

Share this post


Link to post
Share on other sites
Guest Quell

Witam, u mnie na BZZB wtyczka się zainstalowała bez błędów. Niby działa bo wyszukuje i pokazuje wyniki na liście ale przy odtwarzaniu jest pasek postępu i po chwili tylko czarny ekran i tyle, powraca do listy niczego nie odtwarzając.

 

Po update do najnowszej wersji GOS działa poprawnie. Dzieki za tą wtyczkę.

Share this post


Link to post
Share on other sites
Guest robpaupen

Witam. Na najnowszym ADB5800xx_Graterlia_OS_Image wtyczka zainstalowała się bez błędów, podczas instalacji zainstalowało sie również:glibnetworking, libgnutls, libnettle i libgmp. Wtyczka działa bo wyszukuje i pokazuje wyniki na liście ale nie odtwarza wybranego materiału tylko stoi. czego jej potrzeba aby wybrany materiał ruszył?

Share this post


Link to post
Share on other sites
Guest jedrek76

Przekopałem cały internet ale widzę że nie tylko u mnie nie działa mam to samo, buffering 98% i nie chce ruszyć. Jak dam pobierz to pobiera i odtwarza z dysku bez problemu.

Podbijam temat, da się coś z tym zrobić?

 

Wysłane z mojego HUAWEI GRA-L09 przy użyciu Tapatalka

 


Scalono wiadomość: [time]1467260131[/time]

Tom telos zerknąłeś już?

 

Wysłane z mojego HUAWEI GRA-L09 przy użyciu Tapatalka

 

 

Share this post


Link to post
Share on other sites
Guest jedrek76

Niestety opkg nie widzi żadnej aktualizacji, reinstalacja też nie pomaga :(

Share this post


Link to post
Share on other sites

Niestety opkg nie widzi żadnej aktualizacji, reinstalacja też nie pomaga :(

A wogóle masz ostatnio jakieś aktualizacje czegokolwiek? A może na zamrożonym systemie jesteś.

Share this post


Link to post
Share on other sites
Guest jedrek76

Właśnie nie mam żadnych nowych aktualizacji od jakiegoś czasu, czyli jestem w zamrożonym. Czyli reinstalka systemu, czy można go jakoś zaktualizować?

 

Wysłane z mojego HUAWEI GRA-L09 przy użyciu Tapatalka

 

 

Share this post


Link to post
Share on other sites
Guest jedrek76

Reinstalacja poszła bez problemu, wszystko działa, dziękuję. Jeżeli chodzi o informacje na temat przejścia na nowe repo, to brakuje czegoś takiego w faq.

 

Wysłane z mojego HUAWEI GRA-L09 przy użyciu Tapatalka

 

 

Share this post


Link to post
Share on other sites
Guest misiu2000

Reinstalacja pomaga na n-box. Ale na solo2 dalej jest ten problem.

----------------------------------------------------

Dzisiaj wgrałem yotube pobranego z sieci i to samo.

Także wina nie leży w pluginie pobranym z repozytorium.

Share this post


Link to post
Share on other sites

U mnie na Zgemma H2S wtyczka działa oprócz materiałów na żywo. Strumienie z rozszerzeniem .m3u8 nie odtwarzają się. Brakuje jakiejś zależności między pakietami?

Share this post


Link to post
Share on other sites

Witam,czy problem leży u mnie?

 opkg install enigma2-plugin-youtube
Collected errors:
* calculate_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-youtube:
*      gnutls-libs *   glib-networking *
* opkg_solver_install: Cannot install package enigma2-plugin-youtube.

Share this post


Link to post
Share on other sites

problem zależnosci usunięty(super), wtyczka wyszukuje ale nie odtwarza materiałów,chyba ze trzeba cos doinstalowac?

Share this post


Link to post
Share on other sites

E2 log na 4 lub wyżej. Restart GUI i ponownie uruchomić wtyczkę.

następnie podesłać zawartość /var/log

Share this post


Link to post
Share on other sites

Cześć.

 

ZGemma H2.S, świeżo zainstalowany GOS z GUI (+ upgrade do Premium). Zainstalowałem wtyczkę enigma2-plugin-youtube.

Instalacja przebiegła pomyślnie, razem z doinstalowaniem innych wymaganych bibliotek (gstreamer, gnutls, itd.)

Niestety, jak tylko chcę wyszukać jakikolwiek materiał, po wpisaniu pierwszej litery zawiesza się GUI - "zielony ekran" z crashlogiem (w załączeniu).

 

Jakieś rady?

 

 

Dla wątku dałem temat bardziej ogólny. Tak na wszelki wypadek, gdyby pojawiły się inne pytania lub problemy z związane z wtyczką youtube.

 

 

Pozdrawiam,

 

T.

enigma2_crash_1535982920.log

Share this post


Link to post
Share on other sites

Właśnie zaktualizowałem. Jeszcze wczoraj update niczego nie pokazywał ;)

 

Nie ma już problemu z sugestiami. Mogę wyszukać materiał. Niestety, teraz mam problem z samym odtwarzaniem. W załączeniu wycinek z loga.

Tak w skrócie:

libidn2.so.0: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu
Failed to load module: /usr/lib/gio/modules/libgiognutls.so

enigma2_part.log

Share this post


Link to post
Share on other sites

Właśnie zaktualizowałem. Jeszcze wczoraj update niczego nie pokazywał ;)

 

Nie ma już problemu z sugestiami. Mogę wyszukać materiał. Niestety, teraz mam problem z samym odtwarzaniem. W załączeniu wycinek z loga.

Tak w skrócie:

libidn2.so.0: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu
Failed to load module: /usr/lib/gio/modules/libgiognutls.so

Załącz cały log. Z tego wynika, że brak biblioteki ale nie wynika jakiemu pakietowi brakuje tej biblioteki.

Share this post


Link to post
Share on other sites

libidn2.so.0: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu
Failed to load module: /usr/lib/gio/modules/libgiognutls.so

 

Tylko, że jest to dziwne....ponieważ....

Plik libgiognutls.so znajduje się w pakiecie glib-networking. W pliku control tego pakietu mamy zależność dla gnutls-libs (>= 3.6.1)

 

Package: glib-networking
Version: 2.54.1
Section: Libraries
Priority: optional
Maintainer: Graterlia OS <graterlia@xunil.pl>
License: LGPLv2
Architecture: mips32el
Depends: glibc (>= 2.26), glib2 (>= 2.54.2), gnutls-libs (>= 3.6.1), ca-certificates
Homepage: http://git.gnome.org/browse/glib-networking/
Source: http://ftp.gnome.org/pub/GNOME/sources/glib-networking/2.54/glib-networking-2.54.1.tar.xz
Description: Networking support for GLib
This package contains modules that extend the networking support in
GIO. In particular, it contains a libproxy-based GProxyResolver
implementation and a gnutls-based GTlsConnection implementation.

Natomiast pakiet glib-networking ma w zależności libidn2:

Package: gnutls-libs
Version: 3.6.3
Section: Libraries
Priority: optional
Maintainer: Graterlia OS <graterlia@xunil.pl>
License: LGPLv2.1+
Architecture: mips32el
Depends: glibc (>= 2.28), libgcc (>= 8.2.0), gmp (>= 6.1.2), libstdc++ (>= 8.2.0), libunistring (>= 0.9.10), zlib (>= 1.2.11), nettle (>= 3.4); libidn2 (>= 2.0.5)
Homepage: http://www.gnu.org/software/gnutls/
Source: ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/gnutls-3.6.3.tar.xz
Description: GnuTLS shared libraries
GnuTLS shared libraries.

 

Share this post


Link to post
Share on other sites

Wszystko wskazuje więc na to, że instalacja gnutls-libs nie pociąga za sobą libidn2

 

Spróbuj odinstalować gnutls-libs z zależnościami, po czym wykonaj próbę ponownej instalacji. Jestem ciekaw czy libidn2 również się zainstaluje.

Share this post


Link to post
Share on other sites

Nie widzę tutaj libidn2:

 

GraterliaOS:~# opkg depends glib-networking
glib-networking depends on:
        glibc (>= 2.26)
        glib2 (>= 2.54.2)
        gnutls-libs (>= 3.6.1)
        ca-certificates
GraterliaOS:~# opkg depends gnutls-libs
gnutls-libs depends on:
        glibc (>= 2.28)
        libgcc (>= 8.2.0)
        gmp (>= 6.1.2)
        libstdc++ (>= 8.2.0)
        libunistring (>= 0.9.10)
        zlib (>= 1.2.11)
        nettle (>= 3.4)
GraterliaOS:~# opkg depends gnutls
gnutls depends on:
        glibc (>= 2.28)
        gnutls-libs (>= 3.6.3)

Share this post


Link to post
Share on other sites

Niestety, dalej już nie pomogę. Przypomnę tylko, że zainstalowałem najnowszy obraz (ZGemma H2.S). Później aktualizacja (sysupdate), przejście na premium + instalacja wtyczki youtube.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...