Jump to content

NBOX Recorder wymiana dysku


Recommended Posts

Dobry pomysł ze startem z nand. I przy okazji potestuj czy działa wersja nand bo u mnie nie działa :-). Ale jak masz na USB i włożysz nowy dysk to mozesz spróbować wybrać w menu startowym uboot'a start z USB jak nie ma dysku - moze nie widzi nowego dysku.

Link to post
Share on other sites

Ma to znaczenie - Jak zauważysz jest USB"B" co prawdopodobnie oznacza /dev/sd"b"1 - ponieważ dysk zajął miejsce /dev/sd"a"x  - jak startujesz ze starym dyskiem to daj "lsblk -f" lub "fdisk -l". Natomiast jak dysk jest nie widoczny przez system, to USB zajmuje pierwsze wolne miejsce czyli staje sie /dev/sd"a"1 bo nie jest ono zajęte przez dysk. Nie wiem jakie masz wpisy w uboot ale jak włożysz nowy dysk to wybierz USB"A" (UsbA). A kwestia nand nadal aktualna w ramach testów.

Znalazłem jakie masz najprawdopodbniej wpisy:

set bootdesc_0 USbA

set bootcmd_0 'run bootargs_0; run bootkern_0'

set bootkern_0 'usb reset; ext2load usb 0:1 a5000000 /boot/uImage; bootm a5000000'

set bootargs_0 "set bootargs console=ttyAS0,115200 root=/dev/sda1 rw mem=128m coprocessor_mem=4m@0x10000000,4m@0x10400000 rootdelay=6 nwhwconf=device:eth0,hwaddr:${ethaddr} init=/bin/devinit"

 

set bootdesc_1 USbb

set bootcmd_1 'run bootargs_1; run bootkern_1'

set bootkern_1 'usb reset; ext2load usb 0:1 a5000000 /boot/uImage; bootm a5000000'

set bootargs_1 "set bootargs console=ttyAS0,115200 root=/dev/sdb1 rw mem=128m coprocessor_mem=4m@0x10000000,4m@0x10400000 rootdelay=6 nwhwconf=device:eth0,hwaddr:${ethaddr} init=/bin/devinit"

Link to post
Share on other sites
  • 1 month later...

Miałeś rację, aczkolwiek aktualnie sytuacja wygląda tak, że nbox nie widzi innych dysków niż oryginalny - możliwe jest by miał zabezpieczenie?

- podpinam inny dysk i uruchamiam z usbA... ładuję się ale fdisk -l pokazuje tylko pendrive.

- podpinam jeszcze inny dysk tym razem nówkę sztukę - odpala się wisi na "LOAD" po 2 lub 3 minutach przestaje czytać z pendrive i wisi na "LOAD"

- zapinam stary dysk i ładuje z usbB - system wstaje i widzi stary dysk ...

 

Jakieś pomysły?

 

Link to post
Share on other sites

Coś ewidentnie jest nie tak ... podłączyłem jeszcze zupełnie inne dwa dyski i ładuje się system przez ok 2 minuty po czym przestaje czytać z pendrive i stoi na "LOAD"

Dyski na pewno maja mały pobór bo działają też w kieszeni usb na usb 2.0 ...

 

EDIT :

ok poszło na 6tym dysku :) 2,5 cala toshiba 500GB

 

dysk był używany pod windowsem, usunąłem partycje a następnie :

założyłem partycje

 

 

 

Device     Boot Start       End   Sectors   Size Id Type

/dev/sda1        2048 976773167 976771120 465.8G 83 Linux

[/code]

 

Format :

 

 

GraterliaOS:~# mkfs.ext4 -L"records" /dev/sda1
mke2fs 1.44.1 (24-Mar-2018)
Suggestion: Use Linux kernel >= 3.18 for improved stability of the metadata and journal checksum features.
Creating filesystem with 122096390 4k blocks and 30531584 inodes
Filesystem UUID: 5ff155f2-6893-442d-8d6f-05bf113e0280
Superblock backups stored on blocks:
       32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
       4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
       102400000

Allocating group tables: done
Writing inode tables: done
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information: done

 

ale chyba nie ma tej partycji sformatowanej :

 

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1        2048 976773167 976771120 465.8G 83 Linux

 

Przy próbie montowania mam błąd :

 

 

GraterliaOS:~# mount /dev/sda1 /hdd
mount: mounting /dev/sda1 on /hdd failed: Invalid argument

 

 

Link to post
Share on other sites

komenda cfdisk /dev/sda  twierdzi, że dysk jest jednak zamontowany.

Jednak w df -h nie widać tego .

 


   Device        Boot       Start          End      Sectors      Size    Id Type
>>  /dev/sda1                 2048    976773167    976771120    465.8G    83 Linux

┌────────────────────────────────────────────────────────────────────────────────────┐
│  Partition type: Linux (83)                                                        │
│ Filesystem UUID: 5ff155f2-6893-442d-8d6f-05bf113e0280                              │
│Filesystem LABEL: records                                                           │
│      Filesystem: ext4                                                              │
│      Mountpoint: /hdd 

 

EDIT:

 

Sformatowałem jako ext3 i poszło, dlaczego więc nie daje się montować jako ext4?

 

Link to post
Share on other sites

Najwyższy czas aby ktoś ustalił o co chodzi.

Jajko jakie mamy - widać :) i nowsze raczej nie będzie.

e2fsprogs mamy najnowszy. Jeżeli jest coś do poprawki to muszę wiedzieć co bowiem jak wiele razy pisałem - nie mam już tunera SH4.

Link to post
Share on other sites

Zgaduję, że chodzi o "Filesystem features". Gdzieś mkfs ma ustawione "ficzery" domyślne.

 

U mnie na starym ESI88 jest:

 

Filesystem features:      has_journal ext_attr resize_inode dir_index filetype extent flex_bg sparse_super large_file huge_file dir_nlink extra_isize   needs_recovery uninit_bg

 

Na forum było zgłoszone niedziałające:

 

Filesystem features:      has_journal ext_attr resize_inode dir_index filetype extent flex_bg sparse_super large_file huge_file dir_nlink extra_isize   metadata_csum 64bit

 

Czyli:

- zabrano: needs_recovery uninit_bg

+ dodano: metadata_csum 64bit

 

Podejrzewam, że główny problem to ten "ficzer" 64bit. Ale się nie znam :(

Link to post
Share on other sites

Którą wersję e2fsprogs masz na ESI-88?

 

EDIT tux:

Z tego co kojarzę to opcje "features" są ustawiane tutaj: /etc/mke2fs.conf

 

EDIT tux:

Porównanie wersji e2fsprogs_1.43.3 oraz e2fsprogs_1.44.1 pokazuje, że poza usunięciem ext4dev (już nie ma oficjalnie) to dodano w 1.44.1 metadata_csum.

Ktoś kto ma problem musiałby usunąć ten wpis i sprawdzić czy to pomoże.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...